Delayed Metrics
Incident Report for Datadog EU
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 12:05 EDT
Monitoring
We have deployed a fix and we are monitoring the results. We will provide another update once the issue is fully resolved.
Posted Mar 21, 2024 - 11:23 EDT
Identified
We have identified the underlying issue and are working on a fix.

Please note that the Datadog Agent and Client Libraries will buffer data or retry to avoid gaps in data submission.
Posted Mar 21, 2024 - 10:47 EDT
Investigating
We are investigating increased latency processing Metrics. As a result of this issue, some users may see delays or gaps for metrics on graphs.

This is causing delays in Monitors Notifications, which began at 14:01 UTC.
Posted Mar 21, 2024 - 10:20 EDT
This incident affected: Metrics and Infra Monitoring and Monitors.