Degraded Web Application Performance

Incident Report for Datadog EU

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 10:47 UTC

Monitoring

We have deployed a fix and we are monitoring the results. We will provide another update once the issue is fully resolved.
Posted Jul 30, 2025 - 10:20 UTC

Investigating

We are investigating degraded performance with the web application.
Posted Jul 30, 2025 - 10:05 UTC
This incident affected: Web Application.