Delayed Cloud Network Monitoring Data

Incident Report for Datadog EU

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 15:03 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 25, 2025 - 14:46 EDT

Investigating

We are investigating increased latency processing Cloud Network Monitoring Data.
As a result of this issue, some users may see delayed or missing data for Cloud Network Monitoring resources in the web application or API.
Posted Apr 25, 2025 - 14:24 EDT
This incident affected: Cloud Network Monitoring.