Some metrics monitors and delayed and affecting SLOs

Incident Report for Datadog EU

Resolved

The issue has been fixed, and systems are behaving normally.
Posted Jun 23, 2025 - 11:39 EDT

Identified

We have identified an issue affecting metrics monitors and SLOs that affects a small number of users in EU1. We have determined the cause and started to fix, expecting it to recovery shortly.
Posted Jun 23, 2025 - 11:10 EDT
This incident affected: Monitors.